$re = '/<script[^>]*>[^<]*<script[^>]*doubleclick[^>]*>[^\r\n]*[\r\n\s]*<noscript><[^>]*tile=1[^>]*><img[^>]*><\/a><\/noscript>/';
$str = '<script type="text/javascript">document.write(\'<script src="http://ad.doubleclick.net/adj/ep_communityhp;kw=top;state=\'+state+\';tile=1;dcopt=ist;sz=728x90;ord=\'+ord+\'?" type="text/javascript"></\'+\'script>\')</script>
<noscript><a href="http://ad.doubleclick.net/jump/ep_communityhp;kw=top;state=alaska;tile=1;sz=728x90;ord=12345678?" target="_blank"><img src="http://ad.doubleclick.net/ad/ep_communityhp;kw=top;state=alaska;tile=1;sz=728x90;ord=12345678?" width="728" height="90" border="0" alt=""></a></noscript>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);