using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\d{2})\/([a-zA-Z]{3})\/(\d{4}):(\d{2}):(\d{2}):(\d{2})\s(\+\d{4})]";
string input = @"85.239.101.101 - - [07/Jan/2016:01:00:00 +0100] ""POST /bpwsortsinfo1-3/services/Ortsinfo?wsdl HTTP/1.1"" 200 467 ""-"" ""Axis2"" 449/1883 23 BP7 0
85.239.101.101 - - [07/Jan/2016:01:00:01 +0100] ""POST /bpwsortsinfo1-3/services/Ortsinfo?wsdl HTTP/1.1"" 200 467 ""-"" ""Axis2"" 449/1883 23 BP3 0";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}