import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(\\d{2})\\/([a-zA-Z]{3})\\/(\\d{4}):(\\d{2}):(\\d{2}):(\\d{2})\\s(\\+\\d{4})]";
final String string = "85.239.101.101 - - [07/Jan/2016:01:00:00 +0100] \"POST /bpwsortsinfo1-3/services/Ortsinfo?wsdl HTTP/1.1\" 200 467 \"-\" \"Axis2\" 449/1883 23 BP7 0\n"
+ "85.239.101.101 - - [07/Jan/2016:01:00:01 +0100] \"POST /bpwsortsinfo1-3/services/Ortsinfo?wsdl HTTP/1.1\" 200 467 \"-\" \"Axis2\" 449/1883 23 BP3 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}