# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(\d{2})\/([a-zA-Z]{3})\/(\d{4}):(\d{2}):(\d{2}):(\d{2})\s(\+\d{4})]"
test_str = ("85.239.101.101 - - [07/Jan/2016:01:00:00 +0100] \"POST /bpwsortsinfo1-3/services/Ortsinfo?wsdl HTTP/1.1\" 200 467 \"-\" \"Axis2\" 449/1883 23 BP7 0\n"
"85.239.101.101 - - [07/Jan/2016:01:00:01 +0100] \"POST /bpwsortsinfo1-3/services/Ortsinfo?wsdl HTTP/1.1\" 200 467 \"-\" \"Axis2\" 449/1883 23 BP3 0")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.