const regex = /(?:alt|title|value)="(.+?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:alt|title|value)="(.+?)"', 'g')
const str = `<input type="button" alt="hola hola" name="submit" value="Submit" onclick="modo.classes.ABTesting.doCreateSubmit();" title="hola" alt="hola hola hola"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}