$re = '/(?:alt|title|value)="(.+?)"/';
$str = '<input type="button" alt="hola hola" name="submit" value="Submit" onclick="modo.classes.ABTesting.doCreateSubmit();" title="hola" alt="hola hola hola"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);