#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?si)<(a|h1)\b.*?</\1>(*SKIP)(*F)|(222)"
Local $sString = "<p>111 222 333</p>" & @CRLF & _
"<li>111 222 333</li>" & @CRLF & _
"<h1>111 222 333</h1>" & @CRLF & _
"<h2>111 222 333</h2>" & @CRLF & _
"<strong>111 222 333</strong>" & @CRLF & _
"<p><strong>111 222 333</strong></p>" & @CRLF & _
"<p>111 <a href="">222</a> 333</p>"
Local $sSubst = "<a href="#link">\2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)