# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(a|h1)\b.*?</\1>(*SKIP)(*F)|(222)"
test_str = ("<p>111 222 333</p>\n"
"<li>111 222 333</li>\n"
"<h1>111 222 333</h1>\n"
"<h2>111 222 333</h2>\n"
"<strong>111 222 333</strong>\n"
"<p><strong>111 222 333</strong></p>\n"
"<p>111 <a href=\"\">222</a> 333</p>")
subst = "<a href=\"#link\">\\2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.