const regex = new RegExp('<(a|h1)\\b.*?</\\1>(*SKIP)(*F)|(222)', 'gsi')
const str = `<p>111 222 333</p>
<li>111 222 333</li>
<h1>111 222 333</h1>
<h2>111 222 333</h2>
<strong>111 222 333</strong>
<p><strong>111 222 333</strong></p>
<p>111 <a href="">222</a> 333</p>`;
const subst = `<a href="#link">\2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);