using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"img(?![^<]*<\/img>)";
string input = @"<img href=\""#\"">112233test112233</img>123img123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}