re = /img(?![^<]*<\/img>)/
str = '<img href=\\"#\\">112233test112233</img>123img123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end