using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([""']).*?\2|(?:[^\\ ]+\\\s+)+[^\\ ]+|\S+)";
string input = @"He is a ""man of his"" words\ always\ book 'single quote'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}