$re = '/((["\']).*?\2|(?:[^\\\\ ]+\\\\\s+)+[^\\\\ ]+|\S+)/';
$str = 'He is a "man of his" words\\ always\\ book \'single quote\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);