re = /((["']).*?\2|(?:[^\\ ]+\\\s+)+[^\\ ]+|\S+)/
str = 'He is a "man of his" words\\ always\\ book \'single quote\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end