$re = '/\(W\)\s+((?:19|20)\d{2}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}).*?\bIP:\s*((?:::[a-f\d]+:)?(?:(1\d{2}|2[0-4]\d|25[0-5]|\d{1,2})\.){3}(?-1)),\s*username:\s*\S+/';
$str = '(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);