import Foundation
let pattern = #"\(W\)\s+((?:19|20)\d{2}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}).*?\bIP:\s*((?:::[a-f\d]+:)?(?:(1\d{2}|2[0-4]\d|25[0-5]|\d{1,2})\.){3}(?-1)),\s*username:\s*\S+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)