// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(W\)\s+((?:19|20)\d{2}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}).*?\bIP:\s*((?:::[a-f\d]+:)?(?:(1\d{2}|2[0-4]\d|25[0-5]|\d{1,2})\.){3}(?-1)),\s*username:\s*\S+").unwrap();
let string = "(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}