import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"((?:[a-zA-Z]\\:|\\\\\\\\[\\w\\.]+\\\\[\\w.$]+)\\\\.*.exe)\"";
final String string = "\"\\\\test\\test$\\TEST.exe\" %1\n"
+ "\"\\\\server\\share\\folder\\myfile.exe\" %1\n"
+ "\"\\\\server\\share\\myfile.exe\" %1\n"
+ "\"\\\\123.123.123.123\\share\\folder\\myfile.exe\" --play %1\n"
+ "\"c:\\folder\\myfile.exe\" --asdf %1\n"
+ "\"c:\\Program Files (x86)\\TeamViewer\\TeamViewer_server.exe\" --asdf \"%1\" asdf.exe\n"
+ "\"\\\\server\\share\\fo lder\\myfile.exe\" %1\n"
+ "\"\\\\server\\share\\myf ile.txt\" %1\n"
+ "\"\\\\123.123.123.123\\share\\folder\\my file.exe\" %1\n"
+ "\"c:\\folder\\myfil e.exe\" %1\n"
+ "\"c:\\folder\\myfile WithoutExtension\" %1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}