import Foundation
let pattern = #""((?:[a-zA-Z]\:|\\\\[\w\.]+\\[\w.$]+)\\.*.exe)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"\\test\test$\TEST.exe" %1
"\\server\share\folder\myfile.exe" %1
"\\server\share\myfile.exe" %1
"\\123.123.123.123\share\folder\myfile.exe" --play %1
"c:\folder\myfile.exe" --asdf %1
"c:\Program Files (x86)\TeamViewer\TeamViewer_server.exe" --asdf "%1" asdf.exe
"\\server\share\fo lder\myfile.exe" %1
"\\server\share\myf ile.txt" %1
"\\123.123.123.123\share\folder\my file.exe" %1
"c:\folder\myfil e.exe" %1
"c:\folder\myfile WithoutExtension" %1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)