// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""((?:[a-zA-Z]\:|\\\\[\w\.]+\\[\w.$]+)\\.*.exe)""#).unwrap();
let string = "\"\\\\test\\test$\\TEST.exe\" %1
\"\\\\server\\share\\folder\\myfile.exe\" %1
\"\\\\server\\share\\myfile.exe\" %1
\"\\\\123.123.123.123\\share\\folder\\myfile.exe\" --play %1
\"c:\\folder\\myfile.exe\" --asdf %1
\"c:\\Program Files (x86)\\TeamViewer\\TeamViewer_server.exe\" --asdf \"%1\" asdf.exe
\"\\\\server\\share\\fo lder\\myfile.exe\" %1
\"\\\\server\\share\\myf ile.txt\" %1
\"\\\\123.123.123.123\\share\\folder\\my file.exe\" %1
\"c:\\folder\\myfil e.exe\" %1
\"c:\\folder\\myfile WithoutExtension\" %1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}