using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"match me(?!.*?\<\/a\>)";
string input = @"<a href=""#"">Don't Match Me <span>web</span></a>
match me";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}