const regex = /match me(?!.*?\<\/a\>)/si;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('match me(?!.*?\\<\\\/a\\>)', 'si')
const str = `<a href="#">Don't Match Me <span>web</span></a>
match me`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}