$re = '/match me(?!.*?\<\/a\>)/si';
$str = '<a href="#">Don\'t Match Me <span>web</span></a>
match me';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);