using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*.*(\n.*\n)*\*\/)|(\s*\/\/.*\n)";
string input = @"/* test
test
*/
another test
// test
test
/
Normal line
/* test */
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}