$re = '/(\/\*.*(\n.*\n)*\*\/)|(\s*\/\/.*\n)/m';
$str = '/* test
test
*/
another test
// test
test
/
Normal line
/* test */
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);