re = /(\/\*.*(\n.*\n)*\*\/)|(\s*\/\/.*\n)/m
str = '/* test
test
*/
another test
// test
test
/
Normal line
/* test */
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end