package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){{include_sample\(([^\)]+)`)
var str = `{{include_sample(/global/meta.sample.php)}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}