const regex = /(?<=\d)\.0\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)\\.0\\b', 'gm')
const str = `15.0+abc-3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);