use strict;
my $str = '15.0+abc-3';
my $regex = qr/(?<=\d)\.0\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";