$re = '/proxy for task \[\K.+?(?=from job)/';
$str = '[13.04.2016 03:50:08] <15> Info [RTS] [ProxyLoadAnalyzer] Trying to get best proxy for task [DC-CTACWKSTN02.thenewsgroup.com from job "BC-Prod_Windows-Computac_Workstations_vApp" (task id:bcf87bf5-4692-4426-98cb-dab1b7d87091,';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);