import re
regex = re.compile(r"proxy for task \[\K.+?(?=from job)")
test_str = "[13.04.2016 03:50:08] <15> Info [RTS] [ProxyLoadAnalyzer] Trying to get best proxy for task [DC-CTACWKSTN02.thenewsgroup.com from job \"BC-Prod_Windows-Computac_Workstations_vApp\" (task id:bcf87bf5-4692-4426-98cb-dab1b7d87091,"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")