using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\b00|\+)39[\. ]?)?3\d{2}[\. ]?\d{6,7}\b";
string input = @"hello this is my number +39 3331111111 how are you?";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}