const regex = /(?:(?:\b00|\+)39[\. ]?)?3\d{2}[\. ]?\d{6,7}\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\b00|\\+)39[\\. ]?)?3\\d{2}[\\. ]?\\d{6,7}\\b', '')
const str = `hello this is my number +39 3331111111 how are you?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}