use strict;
my $str = 'hello this is my number +39 3331111111 how are you?';
my $regex = qr/(?:(?:\b00|\+)39[\. ]?)?3\d{2}[\. ]?\d{6,7}\b/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}