import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[1-5]{5}$)(?=.*(\\d)(?:.*\\1){2})(?=.*(?!\\1)(\\d).*\\2)\\d+$";
final String string = "33322\n"
+ "24422\n"
+ "52225\n"
+ "44111\n"
+ "54545\n\n"
+ "12345\n"
+ "11223";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}