re = /^(?=[1-5]{5}$)(?=.*(\d)(?:.*\1){2})(?=.*(?!\1)(\d).*\2)\d+$/m
str = '33322
24422
52225
44111
54545
12345
11223'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end