const regex = /^(?=[1-5]{5}$)(?=.*(\d)(?:.*\1){2})(?=.*(?!\1)(\d).*\2)\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[1-5]{5}$)(?=.*(\\d)(?:.*\\1){2})(?=.*(?!\\1)(\\d).*\\2)\\d+$', 'gm')
const str = `33322
24422
52225
44111
54545
12345
11223`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}