import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\w+$\\n?){20,}";
final String string = "property\n"
+ "subject\n"
+ "recipe\n"
+ "newsletter\n"
+ "news\n"
+ "match\n"
+ "reply\n"
+ "bulletin\n"
+ "joke\n"
+ "annual\n"
+ "greeting\n"
+ "accepted\n"
+ "puzzle\n"
+ "march\n"
+ "meeting\n"
+ "din\n"
+ "order\n"
+ "alert\n"
+ "printer\n"
+ "thursday\n"
+ "case\n"
+ "chicago\n"
+ "member";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}