const regex = /(^\w+$\n?){20,}/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\w+$\\n?){20,}', 'm')
const str = `property
subject
recipe
newsletter
news
match
reply
bulletin
joke
annual
greeting
accepted
puzzle
march
meeting
din
order
alert
printer
thursday
case
chicago
member`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}