# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\w+$\n?){20,}"
test_str = ("property\n"
"subject\n"
"recipe\n"
"newsletter\n"
"news\n"
"match\n"
"reply\n"
"bulletin\n"
"joke\n"
"annual\n"
"greeting\n"
"accepted\n"
"puzzle\n"
"march\n"
"meeting\n"
"din\n"
"order\n"
"alert\n"
"printer\n"
"thursday\n"
"case\n"
"chicago\n"
"member")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.