import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Temperature Range:\\s*(\\d*.*\\)$)";
final String string = "Temperature Range: 44 F to 64 F / 7 C to 18 C (upper) and 51 F to 64 F / 11 C to 18 C (lower)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}