re = /^Temperature Range:\s*(\d*.*\)$)/
str = 'Temperature Range: 44 F to 64 F / 7 C to 18 C (upper) and 51 F to 64 F / 11 C to 18 C (lower)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end