const regex = /^Temperature Range:\s*(\d*.*\)$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Temperature Range:\\s*(\\d*.*\\)$)', '')
const str = `Temperature Range: 44 F to 64 F / 7 C to 18 C (upper) and 51 F to 64 F / 11 C to 18 C (lower)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}