using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"filename[^;=\n]*=(?:(\\?['""])(.*?)\1|(?:[^\s]+'.*?')?([^;\n]*))";
string input = @"attachment; filename=content.txt
attachment; filename*=UTF-8''filename.txt
attachment; filename=""EURO rates""; filename*=utf-8''%e2%82%ac%20rates
attachment; filename=EURO rates; filename*=utf-8''%e2%82%ac%20rates
attachment; filename=""omáèka.jpg""
attachment; filename=\""omáèka.jpg\""
attachment; filename*=iso-8859-1'en'%A3%20rates
attachment; filename=EXAMPLE- I'm ößä.dat; filename*=iso-8859-1''EXAMPLE-%20I%27m%20%F6%DF%E4.dat
Content-Disposition: attachment; filename*=UTF-8''0004-1-002-01-datasheet.pdf;";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}