use strict;
my $str = 'attachment; filename=content.txt
attachment; filename*=UTF-8\'\'filename.txt
attachment; filename="EURO rates"; filename*=utf-8\'\'%e2%82%ac%20rates
attachment; filename=EURO rates; filename*=utf-8\'\'%e2%82%ac%20rates
attachment; filename="omáèka.jpg"
attachment; filename=\\"omáèka.jpg\\"
attachment; filename*=iso-8859-1\'en\'%A3%20rates
attachment; filename=EXAMPLE- I\'m ößä.dat; filename*=iso-8859-1\'\'EXAMPLE-%20I%27m%20%F6%DF%E4.dat
Content-Disposition: attachment; filename*=UTF-8\'\'0004-1-002-01-datasheet.pdf;';
my $regex = qr/filename[^;=\n]*=(?:(\\?['"])(.*?)\1|(?:[^\s]+'.*?')?([^;\n]*))/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}