import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "filename[^;=\\n]*=(?:(\\\\?['\"])(.*?)\\1|(?:[^\\s]+'.*?')?([^;\\n]*))";
final String string = "attachment; filename=content.txt\n"
+ "attachment; filename*=UTF-8''filename.txt\n"
+ "attachment; filename=\"EURO rates\"; filename*=utf-8''%e2%82%ac%20rates\n"
+ "attachment; filename=EURO rates; filename*=utf-8''%e2%82%ac%20rates\n"
+ "attachment; filename=\"omáèka.jpg\"\n"
+ "attachment; filename=\\\"omáèka.jpg\\\"\n"
+ "attachment; filename*=iso-8859-1'en'%A3%20rates\n"
+ "attachment; filename=EXAMPLE- I'm ößä.dat; filename*=iso-8859-1''EXAMPLE-%20I%27m%20%F6%DF%E4.dat\n"
+ "Content-Disposition: attachment; filename*=UTF-8''0004-1-002-01-datasheet.pdf;";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}