using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\B(?!\w)|\b(?=\w))Data\[3\](?:(?<=\w)\b|(?<!\w)\B)";
string input = @" Data[3]=(uint8)Data[1];";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}