$re = '/(?:\B(?!\w)|\b(?=\w))Data\[3\](?:(?<=\w)\b|(?<!\w)\B)/m';
$str = ' Data[3]=(uint8)Data[1];';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);