#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<key>\w+)" & @CRLF & _
" (?<sep>\s*=\s*)" & @CRLF & _
" (?<value>(?:(?!(?&key)(?&sep))[^()=])+)" & @CRLF & _
" (?<par>\((?:[^()]+|(?&par))+\))" & @CRLF & _
")" & @CRLF & _
"(?P<k>(?&key))(?&sep)(?P<v>(?:(?&value)|(?&par)))"
Local $sString = "drop = blah blah blah something keep = bar foo nlah aaaa rename = (a=b d=e) obs=4 where = (foo > 45 and bar == 35 and (bar == 45))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")