import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<key>\\w+)\n"
+ " (?<sep>\\s*=\\s*)\n"
+ " (?<value>(?:(?!(?&key)(?&sep))[^()=])+)\n"
+ " (?<par>\\((?:[^()]+|(?&par))+\\))\n"
+ ")\n"
+ "(?P<k>(?&key))(?&sep)(?P<v>(?:(?&value)|(?&par)))";
final String string = "drop = blah blah blah something keep = bar foo nlah aaaa rename = (a=b d=e) obs=4 where = (foo > 45 and bar == 35 and (bar == 45))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}